News:

 

Topic: Draw Mesh with Snap Vertex On makes line jagged  (Read 65 times)

0 Members and 1 Guest are viewing this topic.

  • No avatar
  • Posts: 67
  • Edge
    • White-creatures
September 26, 2018, 10:56:58 PM
Hi everyone,

I am testing doing a retopo using draw mesh and run into a problem. When I enable vertex snapping, so that my end points stick to existing vertex, because I find that if the end points are not touching the vertex, no geometry will be created, and.. the line I draw becomes jagged because the vertex snapping caused my stroke to snap to vertices on the referenced mesh.


I created a gif to show what I mean...

https://www.dropbox.com/s/pzxzpikgt5cg19v/Draw-mesh-snap-vertex.gif?dl=0

I watched rubberDuck's video and see he doesn't have the problem. Any ideas??

  • No avatar
  • Posts: 3335
  • Developer
  • Administrator
  • Polygon
September 27, 2018, 12:12:33 AM
Freeze the reference object.

  • No avatar
  • Posts: 67
  • Edge
    • White-creatures
September 27, 2018, 12:16:24 AM
Ah, thanks IStonia! now it works! nice~

  • No avatar
  • Posts: 3335
  • Developer
  • Administrator
  • Polygon
September 27, 2018, 12:18:01 AM
Also make sure this option is disabled, Edit > Preference > Options 2 > Snap to frozen object enabled.