News:

 

Topic: Performace boost question  (Read 248 times)

0 Members and 1 Guest are viewing this topic.

  • Posts: 194
  • Spline
    • www.weisheim.com
January 15, 2018, 01:41:19 PM
I have one  question about the performance in Nvil . Since i started created more complex models with Nvil, i noticed couple issues regarding performance in heavy scenes.

I know that is not possible complete to avoid this and needs a good poly management while creating models.
But one i have in mind from other 3d software packages, maybe they "hack" something while previewing high density meshes. For example if you load a high poly model in 3dsmax you can easily rotate the highpoly model without no performance issues, until you go into edit mode where it starts to lacking like hell.
Dont know how to explain, its like a zip model for preview^^

Is it maybe possible to get something similar in Nvil?:)

For example to just load a model as "reference", so its possible to preview for example highpoly human model and only model a separate watch on his hand. I dont need the human as editable object, but i need it to be able to see him and rotate around without performance issues.

It would really help on more complex scenes.

« Last Edit: January 15, 2018, 01:43:34 PM by Woolfy »

  • No avatar
  • Posts: 2093
  • Polygon
January 15, 2018, 02:16:14 PM
View > Object shading > Preview on viewport navigating > preview enabled

and/or

common modeling shortcut tools > Freeze/unfreeze#$

  • Posts: 194
  • Spline
    • www.weisheim.com
January 15, 2018, 03:07:01 PM
Thanks a lot for tip!

Is there maybe a way to increase preview performance? Once i imported high density mesh (frozen now), i have still bad framerate during rotation.

I noticed it gets bit better if i enable backface culling.
« Last Edit: January 15, 2018, 03:10:28 PM by Woolfy »

  • No avatar
  • Posts: 2093
  • Polygon
January 15, 2018, 08:45:47 PM
How many faces does the model have?

  • Posts: 194
  • Spline
    • www.weisheim.com
January 16, 2018, 12:15:27 PM
Polys ca 718000
Tris  ca 1437000
Edges ca 1440000
verts ca 721000

have the numbers from 3dsmax

  • No avatar
  • Posts: 3319
  • Developer
  • Administrator
  • Polygon
January 17, 2018, 11:19:46 AM
I tested a scene with 1,000,000 faces and I have 100 frame per second.

Did you have these two options checked.

View > Object Shading > Back Face In Gray.
View > Object Shading > Show Edges On Unselected.

  • No avatar
  • Posts: 2093
  • Polygon
January 17, 2018, 11:46:28 AM
I tested a scene with 1,000,000 faces and I have 100 frame per second.

How did you manage 100 fps?

On my setup, Nvil default config, empty scene(or with a simple box), fps will not go over 64.
(win7 64; i5 quad; gtx1080)

  • No avatar
  • Posts: 3319
  • Developer
  • Administrator
  • Polygon
January 17, 2018, 12:03:19 PM
I created a standard sphere 12 slices and 11 stacks. Subdivided to subd level 5. I made 4 of them all together. Then I had 100 frame rate.

Now I try again. It is different but I still have 65 frame rate.

  • No avatar
  • Posts: 2093
  • Polygon
January 17, 2018, 12:14:21 PM
I created a standard sphere 12 slices and 11 stacks. Subdivided to subd level 5. I made 4 of them all together. Then I had 100 frame rate.
As I put forward, Nvil will not go over 64 FPS in a default empty scene. Adding subdivided spheres does not increase the fps.

Quote
Now I try again. It is different but I still have 65 frame rate.
Does that indicate a bug?

I thought you had probably locked the fps to 60 again, as it was when you first implimented slimDX. But your post putting forward 100 fps would indicate a differance between the version of Nvil you are using and the one I downloaded/use.




  • No avatar
  • Posts: 3319
  • Developer
  • Administrator
  • Polygon
January 17, 2018, 12:42:16 PM
Yes, I do have a mechanism to lock the frame rate to make sure the cpu usage is not too high. But this mechanism is not 100 percent. The underlying system may affect it. I don't think it is a bug.

I recall that when I had 100 frame rate, I had vs2012 opened and Nvil is loaded through vs2012. For the later test, vs2012 is off.
« Last Edit: January 17, 2018, 12:49:09 PM by IStonia »

  • Posts: 194
  • Spline
    • www.weisheim.com
January 17, 2018, 01:04:23 PM
I just created a object that has around 1 mio tris..

Have here at work intel xeon E5-1650 v4, 64 ram, GTX 1070

View > Object Shading > Back Face In Gray.>>>>>>> That was the Reason!!!!
View > Object Shading > Show Edges On Unselected

I had 12fps, now its 160fps.. It seams like it does not block the the FPS here.
(I have the info from the hud display, dont know are that real numbers.)

Thanks a lot for help!
Dont need more performance anymore!!! :)



« Last Edit: January 17, 2018, 01:08:29 PM by Woolfy »