News:

 

Topic: Workplane  (Read 152 times)

0 Members and 1 Guest are viewing this topic.

  • Posts: 437
  • Triangle
October 04, 2017, 11:12:39 AM
Istonia

No need to be confused.

Align workplane to world ZX
Set navigation space to workplane.

Why does top ortho view of workplane not the same as top ortho view of World space ?

Don't worry about my comment about modifying Steves composite tool so it does this:
Perspective (WP)
Front (wp)
Top (wp)
Right (wp)
Left (wp)
Bottom (wp)
Back (wp)

  • No avatar
  • Posts: 2085
  • Polygon
October 04, 2017, 11:21:33 AM
My questions above were about the odd behaviour of the workplane ortho views compared to world ortho views.
If I align the workplane to World ZX axis, I would expect the top ortho view of the workplane to match the top ortho view of world space but it doesn't.

The workplane views appear to be working correctly.
From your previous post:-
Quote
- Use the tool Workplane Tools >> Align Workplane to World ZX$
- Unlock the workplane (so it rotates freely on the XYZ axis) with Workplane Tools >> Lock/Unlock Workplane$
- Use the tool View Navigation Tools >> Set Navigation Space (Workplane)$
Your workplane is now aligned to which axis?

  • Posts: 437
  • Triangle
October 04, 2017, 11:45:27 AM
Steve

Give it a go on your system as you may get a different result.
 
Align workplane to world XY, then lock it (so it doesn't rotate freely)
Set Navigation space to workplane.

Aligning the workplane to world XY is the same as front ortho view in world space, right ?

When I look at top ortho view of workplane space I'm getting an upside down back ortho view of the model.

PS

Forget about the aligning the workplane to the world ZX axis as there is a bug with setting workplane navigation space to this orientation. It doesn't work for me at all.

If it sounds like I'm contradicting myself from previous posts that is not the case, I had set navigation space to workplane on another world axis and the large WP was displaying, then when I set the workplane to ZX and set the navigation space to workplane again, I assumed it worked because the WP was still showing.
« Last Edit: October 04, 2017, 12:04:24 PM by kevjon »

  • No avatar
  • Posts: 2085
  • Polygon
October 04, 2017, 12:54:21 PM
Align workplane to world XY, then lock it (so it doesn't rotate freely)
Set Navigation space to workplane.

Aligning the workplane to world XY is the same as front ortho view in world space, right ?

When I look at top ortho view of workplane space I'm getting an upside down back ortho view of the model.
That sounds correct.

When orienting the workplane to XY, it is rotating around the X axis which will place the front view showing the top of the model. The top view will now show the bottom of the model.
-----------------------------------------------------------------------------------
Load a model. While in 4 views, rotate the model 90 around the X-axis so the top of the model is now showing in front view. What do you see in the other views.