News:

 

Topic: Clipping issues in orthographic views!!!  (Read 3540 times)

0 Members and 1 Guest are viewing this topic.

  • No avatar
  • Posts: 3323
  • Developer
  • Administrator
  • Polygon
October 05, 2017, 02:17:41 AM
When this option is on, both the camera and focus point will move forward when you zoom in. The only case I can think of using this option is there is something sitting between the camera and the area of interest so the area of interest is hidden behind. In this case, you keep zooming in until the area of interest is visible. Now you should disable this option. Then make a selection inside that area of interest then fire best fit command, alternatively activate the "Set View Focusing Point" and click at the area of interest, this will set camera focus point in that area of interest. Now you can zoom in to very close to the area of interest because the camera focus point will not move only the camera moves and the camera will never pass the focus point.

  • No avatar
  • Posts: 2094
  • Polygon
October 05, 2017, 03:00:13 AM
Hi IStonia,

I did ask at the time as to what the intention of the "Advanced Focus Point On Orthographic View Zooming" was for, as it did not work as I would expect. Looking at it now(I dont use it), it appears to give even more confusing results.



  • No avatar
  • Posts: 2094
  • Polygon
October 05, 2017, 04:24:24 AM
So have been taking a longer look at "Advanced Focus Point On Orthographic View Zooming". It is not working.

As explanation:-
I have simple scene(see pic) with 3 box of different colors. I have a viewport set to "Front View", so looking from Z+ to Z-. I select the gray box, and set focus point with "Focus selection". When I zoom in on front view, I cannot zoom past the gray box due to default settings (camera and focus point reach zero).
I zoom back out, and enable "Advance Focus Point on orthographic View Zooming". I zoom back in, and again I am stopped at the grey box, the focus point as not moved. I zoom out, and as I zoom out further, the far clipping plane moves away from camera and clips away the grey box, and as I zoom out further, the blue box is cliped so I see the red box.

Expectation.
"Advanced Focus Point On Orthographic View Zooming" enabled. I set focus point to grey box, in front view I zoom in, as I do, the focus point moves forward with camera, and the grey box is cliped showing the Blue box, and as I zoom further the blue box is cliped and I see the red box.

------------------------
I did a forum search and found a post where I asked about the implimentation, but I gave up.

So I will ask as to the intention of the option, with example of it working.

« Last Edit: October 05, 2017, 04:26:24 AM by steve »

  • Posts: 454
  • Triangle
October 05, 2017, 07:02:31 AM
Steve & Istonia, thanks very much for the explanations about these two camera/viewport features. These are features I have not seen in other 3d software that I have used. Please keep the dialog going.

What is your expectation/needs of how the clipping should work. There are different ways to set it up.

While modelling I don't want to experience any clipping at all. I don't really ever find the need to zoom into the inside of object (for example inside a cube). If an object is obscuring my view I would hide it rather than use viewport clipping. Does my answer help with how to set it up ?

In Modo and 3DS Max I have rarely experienced clipping and don't recall there being any settings for clipping planes. I assume it is programmed to automatically adjust to the size of the objects that the user is modelling. In blender I have far and near clipping planes set as my post above and rarely experience clipping issues.

Now that I have turned off "Advance focus point on orthographic view zooming" and adjusted my far plane scale. give me a couple of days to try the new setup. I will report back further issues but if you have any tips you can pass on it would not only be really useful to me but to others as well.

  • No avatar
  • Posts: 3323
  • Developer
  • Administrator
  • Polygon
October 05, 2017, 08:42:31 AM
steve, I modified the behavior of this option, please have a look.
http://www.digitalfossils.com/Download/NVil-Oct-06-17.rar


-------
Sorry to drag up an old thread but clipping in Nvil is something that keeps plaguing me while modelling. This thread has been an interesting read.

I am seeking guidance on settings as I may be missing something that I need to set or have set wrong ?

I do most of my work in the Custom perspective/ortho view

I have Nvil set to metres
I generally work on models that are between 10 & 20 metres in size.
Some of the smaller components within the model are 0.01m in size which I need to zoom onto.
Custom Front/Back has own camera settings is checked in preferences.
Advance focus point on orthographic view zooming is on in the menus
Scene scale is set to 1
AutoScene scale is turned off
Retopo is not on (as I learned from another thread that affects visual settings)

My Clipping Settings are here


I zoom in and out on the model all the time with ALT+RMB.
I also use Zoom Window command a lot and Zoom selected.
The clipping seems to get worse as the modelling session progresses.

I have to keep hitting "Best Fit All" to get rid of the clipping once it starts happening.

If anyone has any suggestions on things I could do or set differently, I would be most grateful.

kevin, since you have checked the "App auto set far plane base on scene geometry", you should not have problem on far plane clipping. If you have near plane clipping problem, you can either reduce near plane position value or its scale. Make sure your camera focus point is set at the right position.

  • Posts: 454
  • Triangle
October 05, 2017, 09:26:02 AM
Thanks for the help on this Istonia, I really want to get this solved once and for all.

I am not experiencing any far plane clipping at all no matter how far I zoom away from the model.

The problem I still have is with near plane clipping. It doesn't matter how small I set near plane scale 0.01 or 0.001 of a metre it still clips way to early when using Alt+RMB zoom. See attached image.

To get a sense of scale of the object I am zooming onto, the fuselage is about 7 metres long.



You mentioned "near plane position". Where do I find that ?
You mentioned "make sure your camera point is at the right position". How do I do that ? What function in the software controls it ?
« Last Edit: October 05, 2017, 09:28:53 AM by kevjon »

  • No avatar
  • Posts: 3323
  • Developer
  • Administrator
  • Polygon
October 05, 2017, 10:08:24 AM
You mentioned "near plane position". Where do I find that ?

It is the input field for "Near". You need to uncheck the "App auto set" option first.
If the value is tool small, you may have rendering problem in geometries far away from the camera. So set it as big as possible as long as the clipping is ok. You can get the best value from experiencing.




You mentioned "make sure your camera point is at the right position". How do I do that ? What function in the software controls it ?

I have described them in this post.
When this option is on, both the camera and focus point will move forward when you zoom in. The only case I can think of using this option is there is something sitting between the camera and the area of interest so the area of interest is hidden behind. In this case, you keep zooming in until the area of interest is visible. Now you should disable this option. Then make a selection inside that area of interest then fire best fit command, alternatively activate the "Set View Focusing Point" and click at the area of interest, this will set camera focus point in that area of interest. Now you can zoom in to very close to the area of interest because the camera focus point will not move only the camera moves and the camera will never pass the focus point.

  • Posts: 454
  • Triangle
October 05, 2017, 10:14:25 AM
Istonia

After another 1/2 hour of testing.

The image above is in Custom/Orthograhic view. That is when the near clipping occurs way to early.
If I change to Custom/Perspective the near clipping does not occur.

I generally don't work in Custom/Perspective as I find the distortion of the model to much to work effectively so prefer Custom/Orthographic for working on the 3d view of the model.

This is a bug ?

  • No avatar
  • Posts: 2094
  • Polygon
October 05, 2017, 10:21:48 AM
steve, I modified the behavior of this option, please have a look.

That is as I originally thought it had/should of been implimented. That is acting the same as a scene camara(Add Camera) while in ortho view
So why not go in a similar manner for zoom(in ortho) as the "Add Camera" and have no clipping at all?

So it would work as:- You are in ortho view, you can dolly in/out(using "Advance Focus point...", with clipping active), then once that option is disabled, you zoom in/out of current view (no clipping).

If you place a camera into scene for use as ortho view, that is how the camera works.
You have changed how the (Add)cameras work.






« Last Edit: October 05, 2017, 10:31:08 AM by steve »

  • No avatar
  • Posts: 3323
  • Developer
  • Administrator
  • Polygon
October 05, 2017, 11:00:07 AM
Istonia

After another 1/2 hour of testing.

The image above is in Custom/Orthograhic view. That is when the near clipping occurs way to early.
If I change to Custom/Perspective the near clipping does not occur.

I generally don't work in Custom/Perspective as I find the distortion of the model to much to work effectively so prefer Custom/Orthographic for working on the 3d view of the model.

This is a bug ?

It is unlikely a bug. For the same model image size in viewport, ortho and perspective viewport camera's distance to the object can be very different. so the clipping would not be the same.

Do you know how to set camera focus point yet? This is key thing to solve your clipping problem.

  • No avatar
  • Posts: 2094
  • Polygon
October 05, 2017, 11:35:51 AM
Hi IStonia,

Have a look at this simple scene..
Start Nvil and change to Four view. Load scene

The 2 views of interest are the "Custom Perspective" and the "Camera Orthographic"
The clipping for the "Camera Ortho" view is set with both auto off, Near 0.1; Far 25.0
In the "Camera ortho" view, zoom in/out. When zooming in, the camera will stop zooming with no clipping(Maz view), zoom out, and the objects are eventually clipped.
In the "Custom Perps" view, dolly(move) the camera along its Z axis(move toward the objects in scene). The zoom level remains constant, move the camera until you see (in the Camera ortho view) the gray box is clipped away. Now in "Camera ortho" view, zoom in/out. There is no clipping, the gray box does not reappear.

That is how I was expecting the ortho views to work, dolly(move camera in/out with clipping) / zoom(zoom in/out of view with no clipping).
« Last Edit: October 05, 2017, 11:39:26 AM by steve »

  • Posts: 454
  • Triangle
October 05, 2017, 11:38:53 AM

It is unlikely a bug. For the same model image size in viewport, ortho and perspective viewport camera's distance to the object can be very different. so the clipping would not be the same.

Do you know how to set camera focus point yet? This is key thing to solve your clipping problem.

Massive thanks Istonia!

I assigned SHIFT+F to "Set View Focusing Point"

I pointed my cursor at the prop hub of the aircraft and fired Shift+F and now zooming in Custom/Ortho is working perfectly without the clipping issue.

Not only that I can now zoom into my normal Top, Front, Right ortho views to very fine detail without the clipping. If some does occur, I just have to point my cursor and fire Shift+F to fix it.

For me getting this solved is absolutely huge. So thanks again for this !

  • No avatar
  • Posts: 3323
  • Developer
  • Administrator
  • Polygon
October 05, 2017, 12:48:09 PM
Hi IStonia,

Have a look at this simple scene..
Start Nvil and change to Four view. Load scene

The 2 views of interest are the "Custom Perspective" and the "Camera Orthographic"
The clipping for the "Camera Ortho" view is set with both auto off, Near 0.1; Far 25.0
In the "Camera ortho" view, zoom in/out. When zooming in, the camera will stop zooming with no clipping(Maz view), zoom out, and the objects are eventually clipped.
In the "Custom Perps" view, dolly(move) the camera along its Z axis(move toward the objects in scene). The zoom level remains constant, move the camera until you see (in the Camera ortho view) the gray box is clipped away. Now in "Camera ortho" view, zoom in/out. There is no clipping, the gray box does not reappear.

That is how I was expecting the ortho views to work, dolly(move camera in/out with clipping) / zoom(zoom in/out of view with no clipping).

I modified the code to mimic this behavior and I found it has a potential problem. If the near plane is set to auto, when zoom out to some extent, the near plane will start clipping.

  • No avatar
  • Posts: 2094
  • Polygon
October 05, 2017, 05:02:43 PM
I modified the code to mimic this behavior and I found it has a potential problem. If the near plane is set to auto, when zoom out to some extent, the near plane will start clipping.

In its current state, there are still issues.
What would be preferable, a need to disable auto, or a need to keep having to set focus point?

IMO, If you can prevent [ortho view] clipping with one change[disable auto], then that is best option.


  • Posts: 454
  • Triangle
October 05, 2017, 09:08:33 PM
Keep at Istonia, I hope you find a solution.

Zooming is something you are doing all the time, while it was a revelation that is what I had to do solve my clipping issues, I quickly found its not much fun having to set focus point before each and every zoom.