News:

 

Topic: Clipping issues in orthographic views!!!  (Read 3301 times)

0 Members and 1 Guest are viewing this topic.

  • No avatar
  • Posts: 2087
  • Polygon
August 11, 2014, 10:24:43 PM
Hi rubberDuck,

What settings do you have for your ortho view cameras?

Do you have "Edit > Preference > Options > Custom/front/back... view has own camera settings" enabled or disabled?
Do you have "Advance Focus Point on orthographic view zooming" enabled or disabled?


I do not see any issues with ortho camera now, I do use them a lot, but sometimes, depending on camera settings, they may need adjustment.


  • Posts: 898
  • Polygon
August 11, 2014, 10:52:11 PM
Hi rubberDuck,
Hello Steve. Thank you for replying so quickly. I appreciate it!
Quote
What settings do you have for your ortho view cameras?

Do you have "Edit > Preference > Options > Custom/front/back... view has own camera settings" enabled or disabled?
It's enabled.
Quote
Do you have "Advance Focus Point on orthographic view zooming" enabled or disabled?
This I had disabled. I enabled it and it seems to help. At least it looks like it after I did a few quick tests.
When was this option added to NVil anyway?
Quote
I do not see any issues with ortho camera now, I do use them a lot, but sometimes, depending on camera settings, they may need adjustment.
I didn't have any issues with clipping too. And like you, I use them a lot.
Only a few days ago those problems started to appear again. And today I got frustrated so much that I simply had to post here.

So, thank you for your time Steve. It looks like the "Advance focus..." option was the culprit.

  • No avatar
  • Posts: 2087
  • Polygon
August 11, 2014, 11:11:58 PM
Hi rubberDuck,

Do you have "Advance Focus Point on orthographic view zooming" enabled or disabled?
This I had disabled. I enabled it and it seems to help. At least it looks like it after I did a few quick tests.
When was this option added to NVil anyway?

The option was added in update Feb-21-2014. It is on by default, so you may of disabled it by accident/unintentionally at some time.

When the reports of problems was made about the ortho views, IStonia changed the behavior of the ortho cameras so that the view focus point would automatically advance so help prevent clipping. But that could stop all clipping in those views(which can be a problem when wanting to zoom inside an object, such as a building), but it also had a side effect on the "Create polygon" in ortho view, as zooming in/out also changed where the polygon was drawn. So IStonia added the option "Advance Focus Point on orthographic view zooming" so it could be disable and the old behavior used if preferred/required.



« Last Edit: August 11, 2014, 11:22:53 PM by steve »

  • Posts: 898
  • Polygon
August 11, 2014, 11:35:25 PM
Hi rubberDuck,

Do you have "Advance Focus Point on orthographic view zooming" enabled or disabled?
This I had disabled. I enabled it and it seems to help. At least it looks like it after I did a few quick tests.
When was this option added to NVil anyway?
The option was added in update Feb-21-2014. It is on by default, so you may of disabled it by accident/unintentionally at some time.

When the reports of problems was made about the ortho views, IStonia changed the behavior of the ortho cameras so that the view focus point would automatically advance so help prevent clipping. But that could stop all clipping in those views(which can be a problem when wanting to zoom inside an object, such as a building), but it also had a side effect on the "Draw polygon" in ortho view, as zooming in/out also changed where the polygon was drawn. So IStonia added the option "Advance Focus Point on orthographic view zooming" so it could be disable and the old behavior used if preferred/required.
I wonder if this isn't an unnecessary complication. I think I once posted here a video clip that depicted how orthographic cameras are implemented in Maya. They're physical objects existing in the world space, each with a near and far clipping plane attributes.
Zooming in or out never affects clipping planes of Maya's ortho cameras.
Translating those cameras - yes, but what's the point of it? Unless of course the object is huge and stretches way back beyond the camera or the object is located far away from it, beyond the far clipping plane. In such cases you can always dolly the camera forward or back or, if it's the latter - increase the far clipping plane.

  • No avatar
  • Posts: 2087
  • Polygon
August 12, 2014, 12:31:55 AM
Hi rubberDuck,

The ortho view cameras can appear to be over complicated/confusing.

From your expectations of how you want them to work, I would suggest:-

Keep both "Edit > Preference > Options > Custom/front/back... view has own camera settings" and "Advance Focus Point on orthographic view zooming" enabled.(the ortho cameras will only zoom, not dolly forward/backward)
The only time you may see clipping is if you create or import a large object. If you do see clipping, temporarily disable "Advance Focus Point on orthographic view zooming" and zoom back until clipping gone, then re-enable that option.




  • Posts: 898
  • Polygon
August 12, 2014, 12:47:16 AM
I'll do that Steve. Thanks again. :)

  • No avatar
  • Posts: 2087
  • Polygon
August 12, 2014, 12:59:24 AM
You are welcome.

I use the ortho camera settings depending on what I am building. If the model is(for example) a building, where I want to view/work on the inside and outside, then I disable both those options. That way I can move the perspective camera imside the building, then hotkey to set ortho view from that camera position, zooming in/out moves the clipping plane, so I can also zoom in/out of the building in ortho view.

It was my questioning the implementation that made IStonia add the option "Advance Focus Point on orthographic view zooming" so I could revert back to how the ortho view worked before, so I could zoom in/out of objects. So my fault, and sorry for the added complication.

  • Posts: 442
  • Triangle
October 04, 2017, 08:23:51 AM
Sorry to drag up an old thread but clipping in Nvil is something that keeps plaguing me while modelling. This thread has been an interesting read.

I am seeking guidance on settings as I may be missing something that I need to set or have set wrong ?

I do most of my work in the Custom perspective/ortho view

I have Nvil set to metres
I generally work on models that are between 10 & 20 metres in size.
Some of the smaller components within the model are 0.01m in size which I need to zoom onto.
Custom Front/Back has own camera settings is checked in preferences.
Advance focus point on orthographic view zooming is on in the menus
Scene scale is set to 1
AutoScene scale is turned off
Retopo is not on (as I learned from another thread that affects visual settings)

My Clipping Settings are here


I zoom in and out on the model all the time with ALT+RMB.
I also use Zoom Window command a lot and Zoom selected.
The clipping seems to get worse as the modelling session progresses.

I have to keep hitting "Best Fit All" to get rid of the clipping once it starts happening.

If anyone has any suggestions on things I could do or set differently, I would be most grateful.

  • No avatar
  • Posts: 3316
  • Developer
  • Administrator
  • Polygon
October 04, 2017, 09:23:33 AM
Kevin, before I can answer your question, I need to know you understanding of clipping planes. Can you describe what they are and how do they affect the scene?

  • Posts: 442
  • Triangle
October 04, 2017, 11:07:06 AM
My understanding is that if I move my virtual camera closer than 0.1m or further out than 100 metres clipping will occur.

The only problem I have is I do not know if my virtual camera is moving closer or further than those parameters.

I could goggle it but am I close in my understanding ?

  • No avatar
  • Posts: 3316
  • Developer
  • Administrator
  • Polygon
October 04, 2017, 11:31:37 AM
Yes, your under standing is right. But your understanding of the setting maybe wrong.

In the Auto Settings, 0.1 and 100 is scale values. For example, If the distance of camera focus point to camera is 50 meters, the near plane to camera will be 5 meters, the far plane to camera will be 5000 meters. In your settings, Advance focus point on orthographic view zooming is on, so when you zoom in your camera focus point is moving forward to maintain the distance of camera focus point to camera and this will move the camera focus point over to the other side of the model. I would suggest to turn off this option or reduce the far plane scale

  • Posts: 442
  • Triangle
October 04, 2017, 11:50:42 AM
Thanks Istonia

I'll experiment with those two suggestions and see if I can find the magic far plane scale number that work for me.

  • No avatar
  • Posts: 3316
  • Developer
  • Administrator
  • Polygon
October 05, 2017, 01:19:20 AM
I wonder why you turn on this option, Advance focus point on orthographic view zooming. Do you know what it does?

  • Posts: 442
  • Triangle
October 05, 2017, 02:00:07 AM
Istonia

I do not have any idea what it does.

Having said that I do not have any idea what preference setting of "custom front/back has own camera settings" does either.

I think I had lots of clipping issues when I started learning Nvil and didn't find anything in the help file about how to solve it. I found this thread which suggested turning these things on. Which I did to see if it would help. Its probably been left on since.

  • No avatar
  • Posts: 2087
  • Polygon
October 05, 2017, 02:12:12 AM
I do not have any idea what it does.
It will keep the focus point at a set distance from camera. But if you use functions such as "Best Fit", "Selection Focusing" etc, it will change the focus point so will then change clipping.

Quote
Having said that I do not have any idea what preference setting of "custom front/back has own camera settings" does either.
By default there is one camera per viewport, the camera can be changed to front, back etc, but its position remains the same. If you enable "Custom front/back...." it will add a camera for each of the views for the viewports. It means when you change view, it changes to a new camera and its position will be the same as you left it when in that view previously.

Quote
I think I had lots of clipping issues when I started learning Nvil and didn't find anything in the help file about how to solve it. I found this thread which suggested turning these things on. Which I did to see if it would help. Its probably been left on since.
What is your expectation/needs of how the clipping should work. There are different ways to set it up.