News:

 

Topic: [FIXED(1)]Selection bugs  (Read 2565 times)

0 Members and 1 Guest are viewing this topic.

  • No avatar
  • Posts: 69
  • Edge
    • my blog - sculpting
February 25, 2012, 12:30:57 PM
Hi,
1)  Painting selection with 'X' button or MMB, or rectangle select (probably other modes too) causes random faces to be selected all over the mesh.
Note: you have to be zoomed in into part of mesh when painting selection just like in image below, for bug to show. Also mesh in imported from external app (zbrush decim master), but this bugs shows its face often even from meshes created completly in Nvil.

2)  I'm not sure if this is more of feature request (maybe alreday possible?) when selecting with rectangle select it selects faces behind ones that I wanted to select. See animated gif to see what I have in mind. I guess this is useful sometimes, but usually I want to select most front ones faces, not the ones behind.

I attached mesh from images  below.


damm those attachement sizes are way so low. Rectangle select gif from tinypic:
This image is for feature request 2)


Image for bug 1) is in attachment.
« Last Edit: March 02, 2012, 12:27:59 PM by JoseConseco »

  • Posts: 551
  • Administrator
  • Polygon
March 01, 2012, 12:49:36 PM
i haven't been able to recreate any of your issues with either the February 26th build or the march st builds of nvil.

and i tried using the mesh you provided.

olny thing that seems off about the mesh to me is that it is extremely small olny 2 units tall.


  • No avatar
  • Posts: 69
  • Edge
    • my blog - sculpting
March 01, 2012, 05:22:52 PM
Thanks for testing Passerby. Did you zoomed mesh so only face was visible on your screen? This bug (1) won't show itself if you have whole mesh visible on screen and then select some faces.

Steps to reproduce:
- zoom into mesh head so it fills whole screen
- paint polygon selection with 'x' key on area around model nose (or any other selection method ((only shift works ok)))
- if you zoom out you will have random faces selected on whole mesh.
I was able to reproduce in with newest build from today, and at work too. I is old bug, but just now I was able to understand how it works.

  • No avatar
  • Posts: 3323
  • Developer
  • Administrator
  • Polygon
March 02, 2012, 09:27:37 AM
Jose: I think the random bug is fixed. But there is no solution for the second bug yet as some functions missing in the software I am using.

  • No avatar
  • Posts: 160
  • Spline
    • Portfolio
March 02, 2012, 10:53:02 AM
I think I might have been getting this paint through bug also but I thought it was something I had broken, so I changed Switch paint select from MMB to LMB in the Preferences.

p.s. my bad, I just noticed that this doesn't fix the issue.
« Last Edit: March 02, 2012, 10:57:07 AM by ghib »
Senior 3D Artist

  • No avatar
  • Posts: 69
  • Edge
    • my blog - sculpting
March 02, 2012, 12:27:36 PM
Seemms to be fixed thanks IStonia!

  • No avatar
  • Posts: 160
  • Spline
    • Portfolio
March 02, 2012, 02:43:55 PM
It's still broken if you have subdivided your model, but fixed otherwise.
Senior 3D Artist

  • No avatar
  • Posts: 3323
  • Developer
  • Administrator
  • Polygon
March 02, 2012, 09:24:34 PM
ghib: Can you show the problem in subd in a picture?

  • No avatar
  • Posts: 160
  • Spline
    • Portfolio
March 03, 2012, 10:42:03 AM
I don't have video capture software on this computer right now I'm afraid.
These steps should help you reproduce though:

  • Create a box with all segments set to 3 or more
  • Increase Subdivision a few times
  • goto Polygon mode
  • press Q to goto select tool.
  • MMB paint select a bunch of front faces
  • rotate to back of model and notice that some faces have also been selected.

I just noticed now that checking 'Cull BackFacing'  stops this from happening in subdivided mode.
Please also note that with an unsubdivided mesh this issue doesn't happen regardless of whether Culling is set to backfaces or none.
Senior 3D Artist

  • Posts: 85
  • Edge
March 03, 2012, 01:01:40 PM
I don't have video capture software on this computer right now I'm afraid.
These steps should help you reproduce though:

  • Create a box with all segments set to 3 or more
  • Increase Subdivision a few times
  • goto Polygon mode
  • press Q to goto select tool.
  • MMB paint select a bunch of front faces
  • rotate to back of model and notice that some faces have also been selected.

I just noticed now that checking 'Cull BackFacing'  stops this from happening in subdivided mode.
Please also note that with an unsubdivided mesh this issue doesn't happen regardless of whether Culling is set to backfaces or none.

I cannot reproduce this error.
Well, that is the default behavior, as far as I am aware.
You select through the components with MMB,no matter if you're  painting (A) or dragging the rectangle.
If you want to select just front faces use LMB instead of MMB.

Or did I miss something?

  • No avatar
  • Posts: 3323
  • Developer
  • Administrator
  • Polygon
March 03, 2012, 11:55:58 PM
ghib: Your bug should be fixed now.

memag: The default paint select tool does not select through. To select through, 'Caps Lock' key +.

  • Posts: 85
  • Edge
March 04, 2012, 12:06:36 PM
Oh, okay.
I never used it, so I didn't know.