News:

 

Topic: UV's arent exporting in the OBJ format.  (Read 1718 times)

0 Members and 1 Guest are viewing this topic.

  • Posts: 551
  • Administrator
  • Polygon
January 09, 2012, 11:38:09 PM
UV's arent exporting in the OBJ format.

i tried re-importing with both maya and blender and cant get the intact UV;s from a obj exported with Voidworld.
« Last Edit: January 10, 2012, 03:18:52 AM by Passerby »

  • No avatar
  • Posts: 3323
  • Developer
  • Administrator
  • Polygon
January 10, 2012, 03:06:22 AM
Have you checked Edit > Options > File Format Options?

Can you detail the problem?

  • Posts: 551
  • Administrator
  • Polygon
January 10, 2012, 12:39:26 PM
ya on the obj File Format Options, i got Vertex Normals and Regroup polygons by Meshes Checked off, and a export scale of 1.

when i import the exported obj with maya, or blender, the UV's are just completely blank, even if i import the exported obj back into Voidworld.

if i export as the Dae Format i get no issues, and the UV's come across fine.

this isn't a huge deal for me since i don't normally UV in VW, but with shapes made using the slide spline tool, it can be helpful to use the UV's it generates as a starting point.

i ended up having to just delete the geometry i made with the slide+tube tool and remake it with a renderable curve in maya, since those kinda shapes are a huge pain to UV unless you got some auto UVs from the creation of the object.
« Last Edit: January 10, 2012, 12:41:04 PM by Passerby »

  • No avatar
  • Posts: 3323
  • Developer
  • Administrator
  • Polygon
January 10, 2012, 03:05:49 PM
Can you send me a .obj file of a 4 points uved plane exported from maya.

  • Posts: 551
  • Administrator
  • Polygon
January 10, 2012, 03:11:51 PM
here you go

32x32 plane from maya uved to the full 0 to 1 space
http://dl.dropbox.com/u/2360554/Fourms%20Stuff/Void%20World/objissue/uved_plane_maya.obj

32x32 plane from vw, that was uved to the full 0 to 1 space
http://dl.dropbox.com/u/2360554/Fourms%20Stuff/Void%20World/objissue/uved_plane_vw.obj


  • No avatar
  • Posts: 3323
  • Developer
  • Administrator
  • Polygon
January 10, 2012, 09:38:02 PM
In the uved_plane_vw.obj file, vt values are missing. Make sure Edit > Options > File Format Options > obj > Export Textures is checked.

  • Posts: 551
  • Administrator
  • Polygon
January 10, 2012, 09:49:42 PM
that did the job, you might want to change the wording of that option, i thought that would just export out a texture if i had one applied to the mesh in voidworld, not stop it from exporting the UV information.

never would of connected the 2 since in maya, you can disable exporting of textures and materials, and the UV's still get exported.